Jump to content
Amit

Invalid credentials while trying to place a trade

Recommended Posts

I am able to access historical data and market information using the credentials as per the api. When I try to place a trade, I get an error that the credentials are invalid. This is true for both the live account and the demo account. Do I need any further privileges to place a trade?

Share this post


Link to post

Hi Amit,

No. If you can login and request historical data and market information with your account then you shoul dbe able to trade.

I recall a previous client had a similar issue and the root cause is that they mis-typed their login crednetials in the trade/order calls. Every call through the API must contain the authentication information. Have you double checked the login credentials yo uare sending for th etrade/order calls to see if there is a typing error?

Kind Regards, PM 

Share this post


Link to post

Absolutely certain that there are no typos as getting credentials, and including in header for api calls is fully automated. Is it possible that there is an issue with the account number? The demo account number starts with a "DA" followed by 6 digits but the api requires integer for account number. How can I resolve this?

Share this post


Link to post

Hi Amit,

No, the DA or other text string in the account number is fine. 

You mentioned you had the same problem on your Demo account as well as your Live account. Please send me a PM with the account credentials for your DEMO account. I'll login with that account and attempt to place some test trades and see what happens. 

Also, do you have a screenshot of the exact error messages you receive when attempting to place trades/orders?

Kind Regards, PM

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×