Jump to content

darxis

Members
  • Content count

    8
  • Joined

  • Last visited

  1. API Access Denied

    Hi again @Physicsman I am experiencing the same issue again, could you please help me again with escalating this issue so I don't have to wait months until my IP is unblocked? Thanks
  2. API Access Denied

    Thank you very much Physicsman
  3. API Access Denied

    It turned out that my support tickets were already handled by the Client Services supervisor, he said that the only thing he can do is to write follow-ups to the IT team, and he done that already many times, and they just ignore this issue... It is still unresolved, 4 months later, nice Forex.com support...
  4. API Access Denied

    Hi @Physicsman I am not a US customer. On the chat support they told me to contact the "apisupport" email so I have done so. When emailing it I receive a ticket reference number, so I assume it is tracked. Regards
  5. API Access Denied

    I have been contacting the API support team through the "apisupport@gaincapital.com" for nearly 5 months, and they still haven't looked at this issue... I have reminded them several times about this issue, and they always responded that they will forward my request to the API team. They have done nothing about this issue... Very dissapointing My IP is still blocked... I can't access the API at all for 5 months...
  6. API Access Denied

    Physicsman, Thanks for your reply. I have checked the client reputation lookup tool, and it reported that my IP is OK. So I assume it is a policy set by the website owner that has been triggered. I have recontacted the client services, they told me that the tech team will contact me soon. I will update this thread when the issue is fixed.
  7. API Access Denied

    I know, I have been using the API for 3 months without problems. I am manually browsing to https://ciapi.cityindex.com/ just to prove, that it is a Akamai policy that is blocking my IP. Browsing to https://ciapi.cityindex.com/tradingapi/ returns the same "Access Denied" error as well as the endpoint to authenticate ("session"). EDIT: See the below sceenshot. Try to manually browse to https://ciapi.cityindex.com/tradingapi/ and you will not see this error, just my IP will see this because it is blocked. You will get the "Ajax Test Harness" webpage, my IP won't.
  8. Hello, I have been using the API for 3 months. Today, it suddenly stopped working. I receive an "Access Denied" error. When I use a different computer with a different IP it works. I think I have some DNS resolving issues, because when I manually browse to https://ciapi.cityindex.com/ on both computers, I am seeing different webpages (screenshot in attachment, valid.png is from the computer on which API is working, invalid.png is from the computer on which it is not working). I have run the following command to query the Google/OpenDNS DNS servers for ciapi.cityindex.com and it is giving me different results. nslookup ciapi.cityindex.com. 8.8.8.8 Which is giving me the following different results: This one is the result on the machine where the API is not working: C:\Users\Administrator>nslookup ciapi.cityindex.com. 8.8.8.8 Server: google-public-dns-a.google.com Address: 8.8.8.8 Non-authoritative answer: Name: e13934.b.akamaiedge.net Address: 23.43.121.124 Aliases: ciapi.cityindex.com ciapi.cityindex.com.edgekey.net C:\Users\Administrator>nslookup ciapi.cityindex.com. 208.67.222.222 Server: resolver1.opendns.com Address: 208.67.222.222 Non-authoritative answer: Name: e13934.b.akamaiedge.net Address: 23.43.121.124 Aliases: ciapi.cityindex.com ciapi.cityindex.com.edgekey.net And the following one is the result on the machine where the API is working: C:\Users\Administrator>nslookup ciapi.cityindex.com. 8.8.8.8 Server: google-public-dns-a.google.com Address: 8.8.8.8 Non-authoritative answer: Name: e13934.b.akamaiedge.net Address: 104.96.153.135 Aliases: ciapi.cityindex.com ciapi.cityindex.com.edgekey.net C:\Users\Administrator>nslookup ciapi.cityindex.com. 208.67.222.222 Server: resolver1.opendns.com Address: 208.67.222.222 Non-authoritative answer: Name: e13934.b.akamaiedge.net Address: 172.227.187.138 Aliases: ciapi.cityindex.com ciapi.cityindex.com.edgekey.net As you can see, on the "not working" computer, OpenDNS and Google DNS gives me the same, invalid IP, and on the "working" computer it gives me two different IP addresses. I have experienced once the same problem with Akamai when using the time.windows.com NTP server. I have not fixed it, and just switched to another NTP server. Can anyone help me with this issue? I really don't know why the DNS servers are giving me wrong query results on this computer... EDIT I have read that the Access Denied error appears for Akamai websites when the website has policies to block the end user (https://community.akamai.com/customers/s/article/Why-is-Akamai-blocking-me) Please see this thread and fix your blocking policies, so that I can access the API. This screenshot below is taken on a machine with a IP which is not experiencing this problem. And this screenshot below is taken on the machine with the IP experiencing the problem.
×